If your OS’ root certificates are not up to date, uploads to Vidireports will send back a TLS error:


This happens if your PC does not have up-to-date certificate files - Either because it have a very old Ubuntu or Windows version (Vista or XP), or blocked its systems update. This is in particular the case with the Let's Encrypt certificates.


See latest instance for technical details:  https://letsencrypt.org/docs/dst-root-ca-x3-expiration-september-2021/


For more details about Certificate Compatibility: https://letsencrypt.org/docs/certificate-compatibility/ letsencrypt.orgletsencrypt.org


For the list of Quividi certificates: https://crt.sh/?q=quividi.com


In order to solve this issue, please contact your system admin with the above link so he can upgrade your security certificates as soon a possible - On top of stopping any upload to vidicenter, that will stop any license renewal since your box can't connect to Vidicenter.


If you cannot or do not want to update your certificates, there is a workaround that requires you to change an option in the Vidireports control center: go to "Global Settings" and uncheck "Use Strict SSL":




However, please note that this should only be a temporary measure, since it will make VidiReports skip VidiCenter’s certificate validation check.


Note: This only impacts data upload. As long as VidiReports is running, data will still be collected and stored locally. Once the certificates are updated, all data stored on the VidiReports instance will be uploaded into VidiCenter.


You can email help@quividi.com if you need more assistance